Jump to content
IGNORED

Melitta Barista TS 2017 model fails to notice full water tank


danturner
 Share

Recommended Posts

Hi all!

We have a TS that is out of warranty. I can send it for repair but thought i'd double check if this might be something i can resolve myself...

if i fill the water tank and turn the machine on, it makes a "pumping" sound, a bit louder than i recall it being before, and eventually says "Please fill water tank" on the screen. I've tried removing the water filter (and using filtered water directly in the tank) and tried cleaning the brewing unit - although i don't know how to disassemble it so the clean was a "rinse and brush it from the outside" job.

Any ideas would be gratefully received as just the shipping etc. on the repair is fairly expensive!

 

Dan

Link to comment
Share on other sites

I have the TS Smart model which I assume is identical except for the Bluetooth facility.

In your shoes to exclude the obvious possibilities I would first soak the brew unit in cold water for 15 minutes and then rinse thoroughly to clear out any accumulated grind and then clean the coffee system with a Melitta cleaning capsule.

Good luck

Richard

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...