Jump to content
Sign in to follow this  
Australia

Alex Duetta Brew Boiler Not Working

Recommended Posts

I am trying to get an old Alex Duetta working, circa 2009, I believe it is Mach 2. The steam boiler is working fine but the brew boiler shows no pressure and does not provide any water. The machine spuriously throws an alarm, which I thought was associated with the water reservoir sensor not working and shutting down the pump, but I am not convinced that this is the case.


Any ideas? Time for a new pump, or to pull it apart and see if it is blocked? If the latter, which lines in particular?

Share this post


Link to post
Share on other sites
43 minutes ago, Australia said:

I am trying to get an old Alex Duetta working, circa 2009, I believe it is Mach 2. The steam boiler is working fine but the brew boiler shows no pressure and does not provide any water. The machine spuriously throws an alarm, which I thought was associated with the water reservoir sensor not working and shutting down the pump, but I am not convinced that this is the case.


Any ideas? Time for a new pump, or to pull it apart and see if it is blocked? If the latter, which lines in particular?

If there is a low water alarm, the pump will not run.


 Reviews: https://coffeeequipmentreviews.wordpress.com/ YouTube channel: https://tinyurl.com/szhgxzl

I do this as a hobby, I'm not in business and receive no payment for my work a full disclosure is, and always has been, on my review and YouTube sites. Oh, I agree with @dfk41 quite often...well sometimes.

Share this post


Link to post
Share on other sites

Is this the only alarm that the machine has? As I said, I am not convinced that the alarm is the cause, as the machine will run for 15 minutes without it sounding. Any tips for how to get around the issue if it was the alarm, it is not the version of machine that has a switch to isolate the alarm.

Share this post


Link to post
Share on other sites

The only alarm on a Duetto MKII is the buzzer fitted to the Rl30 Gicar box and that's for low water. It disables the pump. Does it run for exactly 15 minutes each time, is it a loose wire, possibly a faulty gicar box.


 Reviews: https://coffeeequipmentreviews.wordpress.com/ YouTube channel: https://tinyurl.com/szhgxzl

I do this as a hobby, I'm not in business and receive no payment for my work a full disclosure is, and always has been, on my review and YouTube sites. Oh, I agree with @dfk41 quite often...well sometimes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • About
    Coffee Forums UK is the UK's premier coffee forum Started in June 2008 by Glenn Watson, we now have more than 24000 mainly UK based members, and welcome more than 3000 members and visitors from around the world each day! With strategic investment and digital expertise from the Jackson Lockhart team (Tait Pollack and Adam Bateman), we are taking Coffee Forums UK to the next level, and are delighted to share the journey with you.

    New Members:
    We are often referred to as the friendliest forum on the web and we look forward to welcoming you onboard. Please read our Terms of Use. We stick by them, existing members please familiarise yourselves with them.

    Advertising

    Coffee Forums Media Kit

    Click Here To Buy Advertising Space 
    £100 p/m when paid yearly, up-to: 690000 banner impressions per month!

     

    coffee-subscription-mini.png

    Become a friend of CFUK
    Buy Us A Monthly Coffee (massive thank you!) 

     

    Donate / Sponsor

    Click Here To Donate (big thank you!)

    Get Your Supporter Badge Today (per year)

    image.png



    Coffee Forums Logo
     

×
×
  • Create New...