Jump to content
IGNORED

New upgraded Lelit on the block - Elizabeth


Recommended Posts

5 hours ago, FrancescoS said:

to give some extra info 

it has been on since 1 pm and I have used it for maybe 8 espresso and a bunch of cappuccino (trying new beans, i don't drink that much!). No weird noises before the backflush, which i have done using Lelit method (button1+water tap)

 

edit. i apologize for the potato quality video 

I have opened up the machine, just to check if there was something obvious to 'fix' - haven't done anything besides touching here and there. the noise seems to have disappeared, but i still have no clue where it came from 😒
 

edit2: I tried again and after pressing the button I hear a buzzing sound. After that the extraction continues 🤔

Some discussion about a similar noises starts here and proceeds over the next page or two...

 

  • Like 1
Link to post
Share on other sites
  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Arrived it has... flushed it’s been.... coffee it made... I was dreading the two hole tip.... worked wonders for a first one!   just couldn’t take the case off (no time, was on lunch br

Ok, will do thanks - just wanted to double check I'd read it right! Now the journey begins to trying to make good coffee... Can't blame the kit 😂

I suppose I'll have a go then... The group of the Minima is very different to the group on the Elizabeth. Yes, it's a 58mm group, the portafilter and the group gasket is the same. And that's it.

Posted Images

11 minutes ago, Paul_from_Oz said:

Some discussion about a similar noises starts here and proceeds over the next page or two...

 

Thank you again! 
the sound from that video is exactly the same as mine - I suppose same problem. 
I will do some more backflush tomorrow and hopefully the issue fixes itself. 
 

in the meantime I have written Lelit and the seller, maybe they have other recommendations as well

Edited by FrancescoS
  • Like 2
Link to post
Share on other sites

Solenoid buzz, probably some debris preventing it from opening fully, so it chatters at 50hz.

It might flush out ? If not contact the retailer. I'm not sure which solenoid it is, but try a backflush with cleaner. It could alternatively be the solenoid from steam boiler that does the preinfusion.

  • Like 1
  • Thanks 1

899161310_ricehaiku.JPG.d69e44c11eab9645400547eea500ba1c.JPG

 

Link to post
Share on other sites

Hello!

I did another chemical backflush this morning and the machine sounded ok for the whole duration. 
also normal brewing with or without preinfusion sounds ok. 
 

bizzare 🤔 I let you know if Lelit says something else, but for the time being everything seems to be working! 
thanks for the help everybody! 

  • Like 1
Link to post
Share on other sites
Posted (edited)
2 hours ago, FrancescoS said:

Hello!

I did another chemical backflush this morning and the machine sounded ok for the whole duration. 
also normal brewing with or without preinfusion sounds ok. 
 

bizzare 🤔 I let you know if Lelit says something else, but for the time being everything seems to be working! 
thanks for the help everybody! 

Something might have got stuck in the solenoid, and now it’s cleared off. 🤞

Edited by MediumRoastSteam
  • Like 1

Current: Lelit Elizabeth / Niche Zero / VST baskets / Distilled water + 100mg NaCO3/L

Previous: Gaggia Classic | Eureka Mignon | Rocket Cellini Evo | Profitec 700 | Profitec T-64 | Gene Cafe CBR-101 | Kinu M68 | Feldgrind 2 | La Pavoni Europiccola 2012

Also at: CoffeeTime Forum & Niche Zero Owners Group

 

Link to post
Share on other sites

Had a knock on the door at about 8am.....very pleased to have received my new Elizabeth!

tried Dialling in (never had an espresso machine before) so that’s still a work in progress but the wife was happy enough with the latte. Said she’d pay for it in a cafe! 
 

ps any advice on setting depth for a lever and tamp? Currently my puck is about 2-3mm below the basket ridge post tamp (18g dose in stock basket)

A42699F8-EA48-4BFC-B9C5-CDADC855F7FB.jpeg

Edited by RobDGio
  • Like 1
Link to post
Share on other sites
17 minutes ago, RobDGio said:

ps any advice on setting depth for a lever and tamp?

Try setting to maximum and compress the puck gently. See where it’s at and adjust accordingly. You want the grinds to be nice and compressed, but don’t over do it.

  • Thanks 1

Current: Lelit Elizabeth / Niche Zero / VST baskets / Distilled water + 100mg NaCO3/L

Previous: Gaggia Classic | Eureka Mignon | Rocket Cellini Evo | Profitec 700 | Profitec T-64 | Gene Cafe CBR-101 | Kinu M68 | Feldgrind 2 | La Pavoni Europiccola 2012

Also at: CoffeeTime Forum & Niche Zero Owners Group

 

Link to post
Share on other sites

Makes sense, thanks. Think my tamp was pretty much set to max depth. I’ll do the same with the leveler too. 
 

now I just need to learn how to pull decent shots!

Link to post
Share on other sites

I'm starting to like Flat whites with single shots so I can have twice as much 🙂

I have a VST 18g and can tell the quality 🙂 also finding this a little strong at times wonder if it's worth investing in 15g basket  to dose less for my doubles  ?

 

Also Is it worth buying the 7g VST will it be massive upgrade over the stock basket ?

Link to post
Share on other sites

Need a quick bit of help. Trying to do an auto back flush (which I though was coffee button one and hot water button) but this doesn’t do anything. I can obviously do it manually by using the purge function with coffee button 1 & 2 (with a blind filter basket for all of the above) but wondered if there is something wrong with my settings. Would prefer to be able to do the “hybrid” back flush that Dave reccomends


I have changed all the advanced lcc settings as per @DavecUKguide and videos. Purge setting for 1&2 set to 6 seconds but as I say the auto back flush doesn’t do anything

any advice would be greatly appreciated 

Link to post
Share on other sites
3 minutes ago, RobDGio said:

Need a quick bit of help. Trying to do an auto back flush (which I though was coffee button one and hot water button) but this doesn’t do anything. I can obviously do it manually by using the purge function with coffee button 1 & 2 (with a blind filter basket for all of the above) but wondered if there is something wrong with my settings. Would prefer to be able to do the “hybrid” back flush that Dave reccomends


I have changed all the advanced lcc settings as per @DavecUKguide and videos. Purge setting for 1&2 set to 6 seconds but as I say the auto back flush doesn’t do anything

any advice would be greatly appreciated 

You have to press and hold the 1 button THEN the water button. If you press them at the same time it won’t start the auto back flush 

  • Thanks 1
Link to post
Share on other sites
47 minutes ago, Del said:

I only know because I did exactly the same thing 🙃

I’m pretty sure every single Elizabeth owner has done exactly the same! I actually thought my machine had a version of the software which didn’t support automatic backflushing! 🤦‍♂️

Current: Lelit Elizabeth / Niche Zero / VST baskets / Distilled water + 100mg NaCO3/L

Previous: Gaggia Classic | Eureka Mignon | Rocket Cellini Evo | Profitec 700 | Profitec T-64 | Gene Cafe CBR-101 | Kinu M68 | Feldgrind 2 | La Pavoni Europiccola 2012

Also at: CoffeeTime Forum & Niche Zero Owners Group

 

Link to post
Share on other sites
On 27/07/2020 at 10:59, DavecUK said:

I set up one button for bloom and one for steam preinfusion, then I switch the steam boiler on or off with the - button, depending on which type of preinfusion I want to use. I sometimes find steam pressure preinfusion works well...sometimes bloom phase. It's always worth trying both.

 

I run my steam boiler at 140C ;)

Sorry if this has been asked before.....

Just to clarify.....will the Elizabeth utilise steam pre infusion if the service boiler is on, And only switch to “bloom” pre infusion if switched off (once these parameters have been set)? Does that mean you’ve set the times you want as per a bloom vs steam preinfusion for the different buttons and access bloom preinfusion by turning steam boiler off? Or do you mean you have specifically been able to eg set button one to do bloom 

Struggling to get my head round all Elizabeth’s functions

sorry to be a pain as I’ve been asking a lot on the forum recently

  • Like 1
Link to post
Share on other sites
15 minutes ago, RobDGio said:

Sorry if this has been asked before.....

Just to clarify.....will the Elizabeth utilise steam pre infusion if the service boiler is on, And only switch to “bloom” pre infusion if switched off (once these parameters have been set)? Does that mean you’ve set the times you want as per a bloom vs steam preinfusion for the different buttons and access bloom preinfusion by turning steam boiler off? Or do you mean you have specifically been able to eg set button one to do bloom 

Struggling to get my head round all Elizabeth’s functions

sorry to be a pain as I’ve been asking a lot on the forum recently

No worries? Did you read / watched Elizabeth's review by @DavecUK? (Very first post of this thread) - If not you, should. It will answer your question here. 

In answer to your question:

- Steam pre infusion when steam boiler is ON;
- Bloom pre infusion when steam boiler is OFF; There are other factors explained in the review, not worth mentioning here)

Each button is able to have a pre-set timer for the shot, and a pre-set time for the pre-infusion, irrespectively of what type of pre-infusion you are using. 

  • Like 1
  • Thanks 1

Current: Lelit Elizabeth / Niche Zero / VST baskets / Distilled water + 100mg NaCO3/L

Previous: Gaggia Classic | Eureka Mignon | Rocket Cellini Evo | Profitec 700 | Profitec T-64 | Gene Cafe CBR-101 | Kinu M68 | Feldgrind 2 | La Pavoni Europiccola 2012

Also at: CoffeeTime Forum & Niche Zero Owners Group

 

Link to post
Share on other sites
1 minute ago, MediumRoastSteam said:

No worries? Did you read / watched Elizabeth's review by @DavecUK? (Very first post of this thread) - If not you, should. It will answer your question here. 

In answer to your question:

- Steam pre infusion when steam boiler is ON;
- Bloom pre infusion when steam boiler is OFF; There are other factors explained in the review, not worth mentioning here)

Each button is able to have a pre-set timer for the shot, and a pre-set time for the pre-infusion, irrespectively of what type of pre-infusion you are using. 

Thank you 

that’s what I though. I have read the review and have watched Dave’s video. Think the sheer level of information was a bit overwhelming and was getting myself confused. 
 

thanks for clarifying

Link to post
Share on other sites
3 minutes ago, RobDGio said:

Thank you 

that’s what I though. I have read the review and have watched Dave’s video. Think the sheer level of information was a bit overwhelming and was getting myself confused. 
 

thanks for clarifying

Yes. It's best to take bit by bit. It's a lot of info to take in. How are you finding the machine?

  • Like 1

Current: Lelit Elizabeth / Niche Zero / VST baskets / Distilled water + 100mg NaCO3/L

Previous: Gaggia Classic | Eureka Mignon | Rocket Cellini Evo | Profitec 700 | Profitec T-64 | Gene Cafe CBR-101 | Kinu M68 | Feldgrind 2 | La Pavoni Europiccola 2012

Also at: CoffeeTime Forum & Niche Zero Owners Group

 

Link to post
Share on other sites
9 minutes ago, MediumRoastSteam said:

Yes. It's best to take bit by bit. It's a lot of info to take in. How are you finding the machine?

Really enjoying things. Steep learning curve as never owned an espresso machine before but getting there.  Having said that I feel I’m getting better shots at home with Elizabeth than your typical high street cafe. So very pleased so far. 
 

thought I’d got the hang of dialling in but still getting different flow rates for shots so wondering if this is more puck prep variations (trying to be consistent) guessing it will all come with practice - also assuming will need to tweak grind with different preinfusion slightly too

pleasantly pleased with ease of steaming milk too. Having never done this before wasn’t expecting anything remotely good but other than not knowing how to do latte art the milk seems perfect for us at home

  • Like 4
Link to post
Share on other sites

When backflushing my machine, I've noticed the pressure displayed doesn't match up with the DaveC's tutorial. 

With a blind basket running the auto flush it reaches 8 bar on the first flush and then 9/10 bar for every other flush. For a manual flush it barely reaches 1 bar on the first flush but then reaches 9/10 for every other flush.

I have the manual flush set to the 6 second maximum. However it appears to dispense slightly less water than the auto flush.

Any advice would be greatly appreciated.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • About
    Coffee Forums UK is the UK's premier coffee forum Started in June 2008 by Glenn Watson, we now have more than 24000 mainly UK based members, and welcome more than 3000 members and visitors from around the world each day! With strategic investment and digital expertise from the Jackson Lockhart team (Tait Pollack and Adam Bateman), we are taking Coffee Forums UK to the next level, and are delighted to share the journey with you.

    New Members:
    We are often referred to as the friendliest forum on the web and we look forward to welcoming you onboard. Please read our Terms of Use. We stick by them, existing members please familiarise yourselves with them.


    Advertising

    Coffee Forums Media Kit

    Click Here To Buy Advertising Space 
    £100 p/m when paid yearly, up-to: 690000 banner impressions per month!


    Donate / Sponsor

    Get Your Supporter Badge Today (per year)

    image.png



    Coffee Forums Logo
     




×
×
  • Create New...