Jump to content
jonny11

Is this normal with steaming? (Sage DB)

Recommended Posts

Posted (edited)

My sage DB broke during lockdown, and I have just received a new one as the old was under warranty.

After having finished all new-start set up, I tried steaming, but it didn't seem the same as before?

It has a good steaming power but there is intermittent 'hard push/jet' as you can see on the video.

Is this normal? or possibly another fault? or will it take time as it's a new machine?

Any input will be grately appreciated.

 

Edited by jonny11

Share this post


Link to post
Share on other sites

No that’s not normal. Looks like some kind of blockage (would normally suggest scale but not on a new machine).

Maybe send that clip to the supplier or Sage themselves and see what they suggest?

Out of curiosity, what failed on your other DB?

Share this post


Link to post
Share on other sites
18 minutes ago, nordberg said:

No that’s not normal. Looks like some kind of blockage (would normally suggest scale but not on a new machine).

Maybe send that clip to the supplier or Sage themselves and see what they suggest?

Out of curiosity, what failed on your other DB?

it was the steaming wand too - after descaling, it stopped working. seems that it's a common problem in DB users.

I've contacted Lakeland, and they will arrange replacement. Hopefully the new one is fine. Not happy after two failures :(

Share this post


Link to post
Share on other sites

DBs aren't, in my experience any more or less reliable than any other consumer grade machines, the attitude of Sage UK with regards to parts availability in the UK is questionable and I also think that hard water/scale and relatively novice users putting tap water in exacerbate problems with Sage machines generally... In other words I suspect they probably aren't as well looked after as their more enthusiast purchased counterparts. They do consist of more plastic parts than say a Gaggia but these don't tend to break or fail that often.

And that definitely isn't normal btw! For sure talk to Lakeland about it!


Decent Pro 1.3, Sage DB (Slayer, Brass OPV and Pump modded, IMS Screen), Titus EK43s SSP Burrs, Mignon Silenzio, Niche coming soon, Osmio Zero.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • About
    Coffee Forums UK is the UK's premier coffee forum Started in June 2008 by Glenn Watson, we now have more than 24000 mainly UK based members, and welcome more than 3000 members and visitors from around the world each day! With strategic investment and digital expertise from the Jackson Lockhart team (Tait Pollack and Adam Bateman), we are taking Coffee Forums UK to the next level, and are delighted to share the journey with you.

    New Members:
    We are often referred to as the friendliest forum on the web and we look forward to welcoming you onboard. Please read our Terms of Use. We stick by them, existing members please familiarise yourselves with them.

    Advertising

    Coffee Forums Media Kit

    Click Here To Buy Advertising Space 
    £100 p/m when paid yearly, up-to: 690000 banner impressions per month!

     

    coffee-subscription-mini.png

    Become a friend of CFUK
    Buy Us A Monthly Coffee (massive thank you!) 

     

    Donate / Sponsor

    Click Here To Donate (big thank you!)

    Get Your Supporter Badge Today (per year)

    image.png



    Coffee Forums Logo
     

×
×
  • Create New...