Jump to content
Jonathan007

Expobar Brewtus DB hot water boiler issue

Recommended Posts

Come to operate the hot water wand on Friday and nothing came out.

I have noticed in the past that the pressure seemed to be dropping but now there is no water at all, not even a sound when I operate the hot water tap/wheel.

Just wondered if anyone has experienced this issue or in fact knows how to fix?

I don't really have a lot of time on my hands to start opening things up.

Share this post


Link to post
Share on other sites

Possibly pressure- stat stuck  OR limit stat needs re-setting. Most likely pressure-stat

  • Like 1

Share this post


Link to post
Share on other sites

Do you still have steam?

  • Like 1

ACS Vesuvius DBPP, Izzo Duetto DB, Minima DB, Lelit Bianca Prototype DB (paddle flow control) BTC Machines: Roasters: Amazon Dalian 1kg Drum Roaster, other failed roasters: Grinders: Ceado E92, Niche US and UK: 145kg assorted greens: My reviews at https://coffeeequipmentreviews.wordpress.com/

Share this post


Link to post
Share on other sites
2 hours ago, DavecUK said:

Do you still have steam?

Steam wand is still as good as ever brew head still good but the hot water, nothing at all...

Share this post


Link to post
Share on other sites
46 minutes ago, Jonathan007 said:

Steam wand is still as good as ever brew head still good but the hot water, nothing at all...

Check for a blockage in the hot water tap...and next time give a bit more information, otherwise you will be led down the garden path. Also location and whether you use hard water or not, recently descaled etc.. can al be useful. Your blockage could be scale or something else...I don't know.


ACS Vesuvius DBPP, Izzo Duetto DB, Minima DB, Lelit Bianca Prototype DB (paddle flow control) BTC Machines: Roasters: Amazon Dalian 1kg Drum Roaster, other failed roasters: Grinders: Ceado E92, Niche US and UK: 145kg assorted greens: My reviews at https://coffeeequipmentreviews.wordpress.com/

Share this post


Link to post
Share on other sites
48 minutes ago, DavecUK said:

Check for a blockage in the hot water tap...and next time give a bit more information, otherwise you will be led down the garden path. Also location and whether you use hard water or not, recently descaled etc.. can al be useful. Your blockage could be scale or something else...I don't know.

Appreciate that Dave thanks.

What I can add is I never hardly ever used the hot water wand at all so I can't imagine it has a blockage.

I'm from Cumbria and I use tap water, always have, it's not hard at all.

When I turn the hot water tap there is nothing, no water no sound, nothing at all, like its dead.

Could it be something other than a blockage. taking into account the minimal amount of times it's been used, I'm talking no more that 5 times.

 

Thanks for the help so far, if you need more info please ask away.

 

Jon

Share this post


Link to post
Share on other sites

Well if the boiler is heating and the steam wand produces steam, the only reason hot water is not coming out is because either there is a blockage, or the valve is faulty, causing a blockage.


ACS Vesuvius DBPP, Izzo Duetto DB, Minima DB, Lelit Bianca Prototype DB (paddle flow control) BTC Machines: Roasters: Amazon Dalian 1kg Drum Roaster, other failed roasters: Grinders: Ceado E92, Niche US and UK: 145kg assorted greens: My reviews at https://coffeeequipmentreviews.wordpress.com/

Share this post


Link to post
Share on other sites

Dave its a twin boiler.
Would this make a difference.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
Share on other sites

The steam wand is fed from the same boiler that feeds the hot water tap...so no, being a twin boiler doesn't matter.


ACS Vesuvius DBPP, Izzo Duetto DB, Minima DB, Lelit Bianca Prototype DB (paddle flow control) BTC Machines: Roasters: Amazon Dalian 1kg Drum Roaster, other failed roasters: Grinders: Ceado E92, Niche US and UK: 145kg assorted greens: My reviews at https://coffeeequipmentreviews.wordpress.com/

Share this post


Link to post
Share on other sites

Just watched a good vid on the tube. I understand it better now thanks. I’ll go check for blockages tomorrow.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • About:

    Coffee Forums UK is the UK's premier coffee forum Started in June 2008 by Glenn Watson, we now have more than 22000 mainly UK based members, and welcome more than 3000 members and visitors from around the world each day! With strategic investment and digital expertise from the Jackson Lockhart team (Tait Pollack and Adam Bateman), we are taking Coffee Forums UK to the next level, and are delighted to share the journey with you.

    New Members:

    We are often referred to as the friendliest forum on the web and we look forward to welcoming you onboard.

    Terms of Use

    Advertising

    Coffee Forums Media Kit

    Buy Advertising Space

    Donate

    Get Your Supporter Badge (per year)

×
×
  • Create New...