Jump to content

Search the Community

Showing results for tags 'heating element'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • New Members Section
    • New Members Section
    • Introductions
  • Coffee Forums
    • Announcements
    • Discounts & Special Offers From Our Advertisers
    • Coffee Lounge
    • Beans
    • Grinders | Machines | Accessories
    • Brewed Coffee
    • Technical | Faults | How-to's
    • Barista Skills for the home enthusiast
    • Show Off Your Setup
    • Videos
    • Home Roasters
    • Find a Coffeeshop
    • Off-Topic
    • Equipment Retailer Reviews
    • Baking and Brewing
    • Coffee Forum Homepage Articles
    • Coffee Wiki
    • The Coffee Map
  • Grinders
    • The Grinder Forum
    • Compak Grinders
    • Ceado Grinders
    • Eureka Grinders
    • Mahlkönig Grinders
    • Mazzer Grinders
    • Niche Zero
  • Coffee Machines
    • Alex Duetto Forum
    • Delonghi Forum
    • Gaggia Forum
    • Expobar Forum
    • Fracino Forum
    • Lever Forum
    • Lelit Forum
    • La Marzocco
    • Quick Mill Forum
    • ECM / Profitec Forum
    • Rancilio Silvia Forum
    • Rocket Forum
    • Sage Forum
    • ACS Ambient Espresso Forum
  • For Sale and Wanted
    • For Sale or Swap
    • Wanted
    • Valuations (What's it worth?)
    • Deals
    • eBay Auction and Gumtree Links
    • Non-Coffee Related Items For Sale
    • Pay it forward
    • Group Buys
  • Tea Forum
    • The Tea Room
  • Coffee Industry
    • Coffee Business Owner Support Forum
    • Commercial | Special Offers
    • Syndicated News and Coffee Tweets from around the world
  • Amateur Barista Championships
  • Misc
    • How Do I?

Product Groups

  • Advertise Your Company
  • Sponsorship & Donations

Blogs

  • Admin's Blog
  • Glenn's Blog
  • coffeeman's Blog
  • CoffeeMagic's Blog

Categories

  • Articles
  • Cafe Reviews
  • Coffee Machine Reviews
  • Coffee Reviews
  • For Sale
  • Wanted
  • Forums
  • Site Advertisers
  • Press Releases

Calendars

  • Community Calendar
  • Coffee Forums UK Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Location


Interests


Occupation


Twitter Account


Telephone Number


First Name


Last Name

Found 9 results

  1. Hey! This is an extremely niche question but maaaaybe someone here knows something that can help me. I got a used Sama (pre-Pontevecchio) Lusso off eBay last year and it worked great until it didn't... Ran dry and blew the heating element and pressurestat. I sent it to Frank at Ferrari Espresso who is looking over it (I got the machine used and wanted to service it anyway) but the elements he'd normally use for a Pontevecchio Lusso (Isomac elements) doesn't fit the Sama as the thread is different. So I need to find another one. I've contacted Pontevecchio to ask if they know any
  2. I provide below a description of the process I went through to solve the problem of a ruptured brew boiler heating element on my Vesuvius. I’d had the Vesuvius for maybe 2 months when I started to notice the brew water had become very cloudy. When I was sure the water was actually always coming out cloudy, I stopped using the machine and asked for help on the forum. Whilst everyone was helpful, I was convinced the problem was not the obvious: needed a good clean, e.g. start backflushing regularly; what kind of water are you putting into it? The water was just too cloudy for these
  3. I have a Rancilio Silvia about 16 months old. It is use daily, but usually once. I always use reverse osmosis water and refill the boiler after steaming by pumping water out through the steam wand. It is fitted with the new EU compliant switch which cuts power after 30 mins. The heater has stopped working. When plugged in to a power outlet the orange thermostat light comes on before the power switch is active. The green light comes on when the power switch is activated and the orange light remains on. No heating takes place but the pump is still active. Do you think that the switch has dev
  4. This morning my girlfriend switched on the Silvia and said it was making a sizzling noise, I came to have a look and the power light wasn't on so I switched it a few times and it didn't turn on. I then noticed that I must have tripped something as nothing else was working in the kitchen so checked the fuse box and flipped it back and it tripped again after the Silvia was turned on. I did a little search and saw that it's usually the heating element or the pump so I just disconnected the heating element terminals and it all lights up. If I put the terminals back on it trips. i just wa
  5. Hi Hopefully somebody can point me in the right direction.My beloved 5 year old Silvia V3 has started to trip my fusebox instantly I turn it on.It doesn't do it after a while or during heat up;its straight away. I have no idea why this might be but after 5 years of excellent coffee,could it be the boiler has failed? Layman's terms only please I need caffeine!! Thanks in advance!
  6. Hi Guys, first post here for me so thanks for any help and advice you can give me. I have an old Silvia which stopped heating up over the weekend. The BOL is constantly on but not getting hot and the pump is working as water is passing through the group head. I have taken the lid off and tried the thermostat reset but it hadn't tripped. I have since broken the little red button as it was very brittle. I then researched and figured it could be a whole host of things and would likely need a multimeter to test. Having disconnected the machine from the mains I put the meter into ohm
  7. Hello.... Ladies/Gents... Recently my La Pavoni, keeps blowing the fuses in my house ! So I decided to investigate.... Horrible horrible amounts of limescale, I couldn't believe the quantity of limescale, so I started to clean everything before investigating the real problem. The problem I think must be; the heating element which is shorting out, or the thermal fuse. The thermal fuse is not the type with the reset button. I doubt the on/off switch is failing, so it can only be either the thermal fuse, or element... My machine is from around 1984/7 ? It has
  8. I don't (or at least didn't) know much about espresso machines, but have been happily using a Gaggia classic for about 5 years until I saw a Rocket Giotto and loved how it looked. But I couldn't justify the cost for a cappuccino or two a day just because it looked nice. A day later, I spotted a faulty ECM Giotto on eBay, all I knew was that it tripped the power when you turn it on. 5 minutes of research told me it was a predecessor to the Rocket Giotto, and so, knowing nothing about how a coffee machine works, I snapped it up for £150 and crossed my fingers that it would be an easy fix instead
  9. Dear all i bought my machine last March from Myespresso and have enjoyed using it for many months. Sadly about 6 weeks ago we started having problems with the electrics and I finally worked out that it was the coffee machine causing the problems. Since then I moved to plunger coffee and there hasn't been a problem. an electrician came round to look at the problem and do some other stuff and he tested the machine by passing a current through the plug pins and he said that it was at fault. 3 days ago I sent it to Myespresso at a cost of £33 and received a call the next day saying
×
×
  • Create New...