Jump to content

Durrsaku

New Members
  • Posts

    8
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Durrsaku's Achievements

Green Bean

Green Bean (2/8)

1

Reputation

  1. At the bottom in the rear in close proximity to steam boiler.
  2. Just a quick update, finally traced the fault to the SSR. Ordered new part (expensive) and installed it. All is now back to normal again working as it should be. In the mean time waiting to fit a heat sink plate hoping it will help. Thank you for all your help.
  3. Thank you, it does have what it appears an Intelligent PID and two Gicar boxes, 1 is the transformer the other the control refill box. I will try and link a photo.
  4. Hi DavecUk, I do appreciate you taking the time to reply so thank you. Yes it is on a RCD of course. It may not be related. Just frustrated that I think I should be able to fix it. I just don't want to end up purchasing parts I don't need to replace. Just trying to understand the circuit diagrams and how the it all works. Thank you.
  5. Just thinking could it be the transformer or the control unit? I have noticed when I switch the steam boiler on that there is current going through the body of the machine. I don't mind taking it for repairs just don't know where to. I am based in Swindon. 🤷🏻‍♂️
  6. Hi, yes I have pressed the button, I also stripped the pipes to the boiler and solenoid just to check if there was any blockage. I am thinking it could be linked to the electronics.
  7. Hi All, I have a two year old QM67. About a month ago the steam boiler stoped working. Not heating up. The brewing capability of the machine is not effected just no steam. I have searched endlessly but have not found what is wrong with it. I have measured the resistance of the heating element and that seems ok. Any help would be much appreciated. thank you
×
×
  • Create New...