Jump to content

dweazel

Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About dweazel

  • Rank
    Green Bean

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. hi jackabb, thanks for your help. i think its what you mentioned right at the start. i'm grinding ithe coffee too fine. i've been grinding it leaving it coarser and it seems to be pouring through. just need to get the right grind to get the stronger flavour and it'll be perfect now. cant express my gratitude enough. i know its something simple but it had me stumped for weeks. much appreciated graeme
  2. thanks for coming back to me Jackabb it is a pressurised basket. when i removed it from the machine there is a lot of water sitting at the top of the ground coffee that cant get through. have you heard of this before? thanks again
  3. Hi all, new to coffee world and new to the forum also. About 4 months ago i bought a delonghi dedica espresso machine. at first it was great but after 2 months it started being temperamental with delivering the shot. Now if i get one cup of coffee it doesnt give me another. makes all the buzzing noise and a little drop of coffee falls into the cup and thats it. i've i've checked and the water and pump are ok and flowing when no filter is on but as soon as the filter and ground coffee is in then nothing comes through. delonghi have mentioned to clean the filter but i've tried and the same thing is happening. iBefore i send this back i want to make sure im not being a noob with it all. i live in scotland and it shouldnt need descaled after this length of time as the water is very soft. also the machine works fine its just getting to the final part of pouring the coffee into the mug. has anyone else experienced this before? if so, any solutions that avoid me sending the machine back? thanks in advance
  4. Hi all, new to coffee world and new to the forum also. About 4 months ago i bought a delonghi dedica espresso machine. at first it was great but after 2 months it started being temperamental with delivering the shot. Now if i get one cup of coffee it doesnt give me another. makes all the buzzing noise and a little drop of coffee falls into the cup and thats it. i've i've checked and the water and pump are ok and flowing when no filter is on but as soon as the filter and ground coffee is in then nothing comes through. delonghi have mentioned to clean the filter but i've tried and the same thing is happening. iBefore i send this back i want to make sure im not being a noob with it all. i live in scotland and it shouldnt need descaled after this length of time as the water is very soft. also the machine works fine its just getting to the final part of pouring the coffee into the mug. has anyone else experienced this before? if so, any solutions that avoid me sending the machine back? thanks in advance
×
×
  • Create New...